« ダウンライトの取り付け(工事篇) | トップページ | LT-H90DTV で予約録画が出来ない »

2009年2月21日 (土)

再三 NAS の HDD がデグレード状態となる BUFFALO への公開質問

 ハードディスクを交換して3週間程調子良く動いていた RAID 機能付 NAS が再びデグレード状態となったメールを送りつけてきた。

 これまでの不具合発生経緯 (上が新しい記事

 今回も NAS から送られてきたメールでディスクを交換しろと勧められている。

DISKエラー通知
HDDでエラーが発生しました。
エラー発生ディスク:ディスク1
(sda) WRITE sector:974984680 count:6
ディスクへの書き込みエラーが発生しました。
エラーが発生した箇所を含むデータは復元できません。

すぐにディスクの交換をお勧めします。

[LinkStation情報]
LinkStation名称: LS-WTGL38F (LS-WTGL/R1)

 もう、これは絶対に本体が故障しているな!交換を勧められてディスクを交換してみたが、NAS が故障と診断したディスクを Seagate の Seatool で Advanced Tests を行って何の問題も報告されなかった訳だし…

 BUFFSHOP の ”訳あり中古商品” だから BUFFSHOP に修理して貰える訳でもないしな。自力で解決するしかないんだよね。

 RAID での運転を諦めて DISK を1台だけで利用出来るかな?万一の安心を買うために RAID を構築しているにも関わらず RAID が故障しないか毎日心配していたのでは本末転倒も良い処だ。

 取り敢えず PC のローカルな HDD に NAS 上のデータ退避を行って、ディスク1台で普通の NAS と同じ様に利用する道を探す。

Delete

再三エラーを引き起こす DISK-1 を取り外して電源を投入し web 設定のディスク管理から RAID アレイの削除を行った。

画像はクリックすると拡大表示されます

Format その後、DISK-2 をフォーマットする
Formatfail

しかし、フォーマットに失敗したと報告されたので、一旦本体の電源を落としてサイド試みるが同じだったので、DISK-1 も繋がないとフォーマット出来ないのかと思い DISK-1 と DISK-2 を接続した状態で立ち上げた。

Emmode

すると2度程再起動が掛かったかと思ったら NASNavigator2 に表示された LS-WTGL は EM モードと表示された。

(DISK-1 は RAID 設定されたままの DISK で、DISK-2 は通常モードに設定されてフォーマットを失敗した DISK)

Emdlg 情報:EMモードを検出しました。ファームウェアアップデートを実行するか、修理センターに連絡ください。(2009/02/20 22:51:47) とダイアログに表示される。

 これ以降、まともに電源すら切ることが出来ない、全くアクセス出来ない状態となってしまった crying

 EM モードと言えば、玄人志向ブランドの LinkStation を裏技改造するのに話題となった Linux で起動するモードのことかと思うが…

Update_2 ここはダイアログに表示された通り、冷静にファームウェアのアップデートを実行してみる。
Change ファームウェアの転送が行われ書き換え作業は無事に終了した。
Wait 再起動の完了待ちに随分と待たされたが、HDD のユーティリティ・フォルダ info にデータを書き込んでいるからだろうか?
Check

Web 設定画面にアクセスすると、現在、フォーマット、またはディスクチェックを実行しています実行中は LinkStation の設定を変更することは出来ませんまた、ファイル共有サービスも停止しています

と表示され待たされる。

Folder この後、PC から LinkStation が見える様になったものの、フォルダにアクセスしようとするとアクセス出来ない。共有フォルダ管理を行っても DISK が1台だと正しく設定出来ないらしい。
Emdlg 仕方なく、2台の HDD を装着して起動し直すと、再起動を2回リトライして再び EM モードとなったのでファームウェアを再度更新する。
Delete2 HDD を2台とした為に RAID が復活して復帰したので、ここで改めて RAID アレイを削除する。
Normal_2 これでやっと通常モード(500GB x 2 台の HDD として)で使用可能となった。orz 疲れた…
Disk12_2 ファームを再ロードすると各種設定がデフォルトに戻るので再度改めて設定し直し、共有フォルダ設定を行って PC に退避していた NAS のデータをリストアした。

 RAID を利用しない状態で以後様子を見ることにする。兎に角この NAS は2台の HDD を搭載しないと、通常モードでもまともに動作出来ないらしい。もし DISK-1 側 SATA の不具合か何かが原因で DISK-1 で再びエラーが発生するなら、DISK-1 にはダミー HDD を搭載する等して DISK-2 だけを使って故障した NAS を有効利用したいと思う。

 いちおう BUFFALO にディスク1台でも利用可能か Webサポートお問合せフォームで質問してみた。

RAID-1 で使用していると必ず RAID がデグレードします。
BUFFSHOP のアウトレット品を購入したのでメーカ保障が
効かず故障修理が出来ないので、HDD 1台だけで運用し
たいのですが、HDD を1台だけ搭載して起動すると色々な
困難に直面して巧く利用出来ません。
(EM モードからの復帰でファームを再ロードしたり…)

型式や容量の違うディスクを DISK-1 に入れて全く使用
しなければ良いでしょうか?

故障の経緯は自分のブログで記載してます。
http://hidekyan.cocolog-nifty.com/blog/2009/02/nas-hdd-3ddc.html

 BUFFALO には上記の通りブログの URL を記した問い合わせを行ったので、見に来てくれるかは判らないが公開質問も兼ねた記事を書いてみた。

ひでのブログ http://hidekyan.cocolog-nifty.com/blog/

|

« ダウンライトの取り付け(工事篇) | トップページ | LT-H90DTV で予約録画が出来ない »

「パソコン・インターネット」カテゴリの記事

コメント

コメントを書く



(ウェブ上には掲載しません)




トラックバック

この記事のトラックバックURL:
http://app.f.cocolog-nifty.com/t/trackback/145636/28245299

この記事へのトラックバック一覧です: 再三 NAS の HDD がデグレード状態となる BUFFALO への公開質問:

« ダウンライトの取り付け(工事篇) | トップページ | LT-H90DTV で予約録画が出来ない »